All Observe.AI services have been restored. Thank you for your patience and If you have any questions or experience any issues please contact Observe.AI Technical Support via the Help Center.
Thank You! Observe.AI Technical Support
Posted Sep 06, 2025 - 02:00 UTC
Monitoring
A fix has been rolled out and we are seeing perfornance returning to normal. We will remain in a state of monitoring for a time before considering this issue fully resolved.
Posted Sep 05, 2025 - 21:53 UTC
Update
Most affected accounts are back to normal. For the remaining few, we have implemented some fixes and are monitoring the progress while we continue to work on making adjustments to resolve the issues.
Posted Sep 05, 2025 - 21:36 UTC
Update
We continue to actively work on the issue with data and filters failing to load on pages. We will continue to provide updates as we have them.
Posted Sep 05, 2025 - 20:16 UTC
Identified
The data on pages is starting to load once more. We continue to work on resolving the loading issue with filters on various pages.
Posted Sep 05, 2025 - 19:22 UTC
Update
We continue to actively troubleshoot this issue and have narrowed down the cause. We will continue to provide updates as they are available.
Posted Sep 05, 2025 - 18:46 UTC
Investigating
We are aware of an issue where various parts of the dashboards are stuck in a loading state and not displaying data. We have engaged the necessary resources and are treating this with the highest priority.