TalkDesk Login Issue
Incident Report for observeai
Resolved
The TalkDesk login issue have been resolved. Thank you for your patience while we’ve been working on this. We know the disruption may have been frustrating and we do appreciate you as a customer. If you have any further issues please submit a ticket via our Help Center.

Thank you!

Observe.AI Technical Support
Posted Oct 15, 2021 - 19:19 UTC
Identified
We have identified an issue with TalkDesk customers not able to log into observe.ai via TalkDesk. We are currently working on resolving this issue, in the meantime please use this URL to access Observe.AI:

https://app.observe.ai/

Thank you for your patience,

Observe.AI Technical Support
Posted Oct 15, 2021 - 18:53 UTC
This incident affected: Login Page.