Latency Issues on Observe.AI Dashboard

Incident Report for observeai

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 17:00 UTC

Monitoring

A fix has been implemented, and the service has returned to normal. We will continue to monitor the system closely.
Posted Oct 30, 2025 - 16:44 UTC

Update

We are continuing to investigate this issue.
Posted Oct 30, 2025 - 16:32 UTC

Investigating

We are currently investigating an issue where you may experience latency when loading certain tabs on the Observe.AI dashboards. Our team is actively working to resolve these issues and restore full functionality.
Posted Oct 30, 2025 - 16:31 UTC
This incident affected: Standard Instance (Instance Wide).